Shockwave Flash

UPDATE 9/9/07

You may NOT need to do anything special with 10.3 Beta 3.

Try these pages FIRST:

http://images.southparkstudios.com/games/create/index.html

AND

http://youtube.com/

If BOTH of these sites WORK for you then DO NOT do anything else on this page!!!

The South Park page sometimes doesn't always work 100% correctly, so don't immediately think that flash isn't working just because that page isn't functioning.  If you can see the flash and the panel for creating your character, flash is probably working.

Otherwise, please continue to read...

If you are running Beta 2 or if you are still having problems, try this before doing ANYTHING else (in a terminal):

nspluginwrapper -a -i

Then restart Mozilla Firefotx.

If BOTH of these sites WORK for you then DO NOT do anything else on this page!!!

http://images.southparkstudios.com/games/create/index.html

AND

http://youtube.com/

Again, if BOTH links work then STOP HERE.

Otherwise, some of the rest of this page may help, but I do NOT recommend it because ALL other plugins will cease to work correctly!!!

Ugh...

WARNING:  The remaining steps on this page may help you to get Flash working 100% in Mozilla Firefox...  BUT BE WARNED:  These steps will definitely BREAK all of your other plugins.

ERROR: Your architecture, \'x86_64\', is not supported by the Adobe Flash Player installer.

If you absolutely do not need Shockwave Flash, or if you don't care, please ignore the rest of this page.

Uninstall Mozilla Firefox 64-Bit

Q:  Wait.  WTF.  Will I lose any functionality or performance if I do this?

A:  Fuck if I know.  It seems the exact same to me.

If you absolutely must have Shockwave Flash support, you will need to do the following:

In YaST Software Manager, uninstall Mozilla Firefox.  You will not lose any settings or extensions.

Install Mozilla Firefox 32-Bit

After it is uninstalled, go back in to YaST Software Manager and search for firefox again.

When you find it, check it, but then click on the "Versions" tab.  From this list shown at the bottom, check a 32-bit version (i586), then click the "Accept" button.

This will install the 32-bit version and will allow Flash to work.

Download & Install Shockwave Flash

Close Firefox before installing!

I used the tar.gz file, extracted it, then ran the shell script:

install_flash_player_9_linux.tar.gz

sh flashplayer-installer

This RPM might work fine, dunno:

flash-plugin-9.0.48.0-release.i386.rpm

su
rpm -ivh flash-plugin-9.0.48.0-release.i386.rpm

Testing

Open Mozilla Firefox.

In the address bar type:  about:plugins

You should see "Shockwave Flash" listed.

If you do, you should be all set.

See if this page works:  South Park Create-A-Character

All good?

Oh, here is my picture:  sgt-d.png

:p~